Windows 10でQuiverのインストールに失敗する場合の対応

Windows 10でQuiverのインストールに失敗する場合の対応方法をご紹介します。

条件

  • Windows 10 64bit

Quiverとは?

畳み込みニューラルネットワークの特徴をインタラクティブな方法で可視化することが出来るソフトです。

詳細は以下のサイトをご確認ください。

https://github.com/keplr-io/quiver

インストール失敗

インストール実行

以下のコマンドでインストールを行いますが、現時点(2019/6/21)で失敗するようです。

> pip install quiver_engine

エラーログ

以下のようなログが出力されます。
よくわからない感じです。

Collecting quiver_engine
  Downloading https://files.pythonhosted.org/packages/57/9a/90f21cf6c092bf6e72dad3e5725c6a0f2fae34a069ce6ad56a00dc1de68e/quiver_engine-0.1.4.1.4.tar.gz (398kB)
Requirement already satisfied: keras in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver_engine) (2.2.4)
Requirement already satisfied: tensorflow in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver_engine) (1.13.1)
Collecting flask (from quiver_engine)
  Downloading https://files.pythonhosted.org/packages/9a/74/670ae9737d14114753b8c8fdf2e8bd212a05d3b361ab15b44937dfd40985/Flask-1.0.3-py2.py3-none-any.whl (92kB)
Collecting flask_cors (from quiver_engine)
  Downloading https://files.pythonhosted.org/packages/78/38/e68b11daa5d613e3a91e4bf3da76c94ac9ee0d9cd515af9c1ab80d36f709/Flask_Cors-3.0.8-py2.py3-none-any.whl
Collecting gevent (from quiver_engine)
  Downloading https://files.pythonhosted.org/packages/8a/dd/417aad4e69fa7f8882534b778c46cb28eb0421ffa1e924ec3b4efcfcc81f/gevent-1.4.0-cp37-cp37m-win_amd64.whl (3.0MB)
Requirement already satisfied: numpy in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver_engine) (1.16.4)
Collecting pillow (from quiver_engine)
  Downloading https://files.pythonhosted.org/packages/40/f2/a424d4d5dd6aa8c26636969decbb3da1c01286d344e71429b1d648bccb64/Pillow-6.0.0-cp37-cp37m-win_amd64.whl (2.0MB)
Requirement already satisfied: scipy>=0.14 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver_engine) (1.3.0)
Requirement already satisfied: keras-applications>=1.0.6 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver_engine) (1.0.8)
Requirement already satisfied: keras-preprocessing>=1.0.5 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver_engine) (1.1.0)
Requirement already satisfied: pyyaml in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver_engine) (5.1.1)
Requirement already satisfied: six>=1.9.0 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver_engine) (1.12.0)
Requirement already satisfied: h5py in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver_engine) (2.9.0)
Requirement already satisfied: absl-py>=0.1.6 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (0.7.1)
Requirement already satisfied: tensorflow-estimator<1.14.0rc0,>=1.13.0 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (1.13.0)
Requirement already satisfied: astor>=0.6.0 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (0.8.0)
Requirement already satisfied: gast>=0.2.0 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (0.2.2)
Requirement already satisfied: protobuf>=3.6.1 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (3.8.0)
Requirement already satisfied: grpcio>=1.8.6 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (1.21.1)
Requirement already satisfied: wheel>=0.26 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (0.33.4)
Requirement already satisfied: tensorboard<1.14.0,>=1.13.0 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (1.13.1)
Requirement already satisfied: termcolor>=1.1.0 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow->quiver_engine) (1.1.0)
Collecting click>=5.1 (from flask->quiver_engine)
  Using cached https://files.pythonhosted.org/packages/fa/37/45185cb5abbc30d7257104c434fe0b07e5a195a6847506c074527aa599ec/Click-7.0-py2.py3-none-any.whl
Collecting Jinja2>=2.10 (from flask->quiver_engine)
  Downloading https://files.pythonhosted.org/packages/1d/e7/fd8b501e7a6dfe492a433deb7b9d833d39ca74916fa8bc63dd1a4947a671/Jinja2-2.10.1-py2.py3-none-any.whl (124kB)
Collecting itsdangerous>=0.24 (from flask->quiver_engine)
  Downloading https://files.pythonhosted.org/packages/76/ae/44b03b253d6fade317f32c24d100b3b35c2239807046a4c953c7b89fa49e/itsdangerous-1.1.0-py2.py3-none-any.whl
Requirement already satisfied: Werkzeug>=0.14 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from flask->quiver_engine) (0.15.4)
Collecting greenlet>=0.4.14; platform_python_implementation == "CPython" (from gevent->quiver_engine)
  Downloading https://files.pythonhosted.org/packages/90/a3/da8593df08ee2efeb86ccf3201508a1fd2a3749e2735b7cadb7dd00416c6/greenlet-0.4.15-cp37-cp37m-win_amd64.whl
Collecting cffi>=1.11.5; sys_platform == "win32" and platform_python_implementation == "CPython" (from gevent->quiver_engine)
  Downloading https://files.pythonhosted.org/packages/2f/ad/9722b7752fdd88c858be57b47f41d1049b5fb0ab79caf0ab11407945c1a7/cffi-1.12.3-cp37-cp37m-win_amd64.whl (171kB)
Requirement already satisfied: mock>=2.0.0 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorflow-estimator<1.14.0rc0,>=1.13.0->tensorflow->quiver_engine) (3.0.5)
Requirement already satisfied: setuptools in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from protobuf>=3.6.1->tensorflow->quiver_engine) (41.0.1)
Requirement already satisfied: markdown>=2.6.8 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from tensorboard<1.14.0,>=1.13.0->tensorflow->quiver_engine) (3.1.1)
Collecting MarkupSafe>=0.23 (from Jinja2>=2.10->flask->quiver_engine)
  Using cached https://files.pythonhosted.org/packages/65/c6/2399700d236d1dd681af8aebff1725558cddfd6e43d7a5184a675f4711f5/MarkupSafe-1.1.1-cp37-cp37m-win_amd64.whl
Collecting pycparser (from cffi>=1.11.5; sys_platform == "win32" and platform_python_implementation == "CPython"->gevent->quiver_engine)
  Using cached https://files.pythonhosted.org/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz
Building wheels for collected packages: quiver-engine, pycparser
  Building wheel for quiver-engine (setup.py): started
  Building wheel for quiver-engine (setup.py): finished with status 'error'
  Running setup.py clean for quiver-engine
  Building wheel for pycparser (setup.py): started
  Building wheel for pycparser (setup.py): finished with status 'done'
  Stored in directory: C:\Users\user\AppData\Local\pip\Cache\wheels\f2\9a\90\de94f8556265ddc9d9c8b271b0f63e57b26fb1d67a45564511
Successfully built pycparser
Failed to build quiver-engine
Installing collected packages: click, MarkupSafe, Jinja2, itsdangerous, flask, flask-cors, greenlet, pycparser, cffi, gevent, pillow, quiver-engine
  Running setup.py install for quiver-engine: started
    Running setup.py install for quiver-engine: finished with status 'error'

  ERROR: Complete output from command 'C:\Users\user\AppData\Local\Programs\Python\Python37\python.exe' -u -c 'import setuptools, tokenize;__file__='"'"'C:\\Users\\user\\AppData\\Local\\Temp\\pycharm-packaging\\quiver-engine\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d 'C:\Users\user\AppData\Local\Temp\pip-wheel-cry_3y4a' --python-tag cp37:
  ERROR: running bdist_wheel
  running build
  running build_py
  creating build
  creating build\lib
  creating build\lib\quiver_engine
  copying quiver_engine\imagenet_utils.py -> build\lib\quiver_engine
  copying quiver_engine\layer_result_generators.py -> build\lib\quiver_engine
  copying quiver_engine\server.py -> build\lib\quiver_engine
  copying quiver_engine\util.py -> build\lib\quiver_engine
  copying quiver_engine\__init__.py -> build\lib\quiver_engine
  running egg_info
  writing quiver_engine.egg-info\PKG-INFO
  writing dependency_links to quiver_engine.egg-info\dependency_links.txt
  writing requirements to quiver_engine.egg-info\requires.txt
  writing top-level names to quiver_engine.egg-info\top_level.txt
  reading manifest file 'quiver_engine.egg-info\SOURCES.txt'
  reading manifest template 'MANIFEST.in'
  writing manifest file 'quiver_engine.egg-info\SOURCES.txt'
  Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "C:\Users\user\AppData\Local\Temp\pycharm-packaging\quiver-engine\setup.py", line 21, in <module>
      'pillow'
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\__init__.py", line 145, in setup
      return distutils.core.setup(**attrs)
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\core.py", line 148, in setup
      dist.run_commands()
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\dist.py", line 966, in run_commands
      self.run_command(cmd)
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\dist.py", line 985, in run_command
      cmd_obj.run()
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\wheel\bdist_wheel.py", line 192, in run
      self.run_command('build')
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\cmd.py", line 313, in run_command
      self.distribution.run_command(command)
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\dist.py", line 985, in run_command
      cmd_obj.run()
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\command\build.py", line 135, in run
      self.run_command(cmd_name)
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\cmd.py", line 313, in run_command
      self.distribution.run_command(command)
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\dist.py", line 985, in run_command
      cmd_obj.run()
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 53, in run
      self.build_package_data()
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 118, in build_package_data
      for package, src_dir, build_dir, filenames in self.data_files:
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 66, in __getattr__
      self.data_files = self._get_data_files()
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 83, in _get_data_files
      return list(map(self._get_pkg_data_files, self.packages or ()))
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 95, in _get_pkg_data_files
      for file in self.find_data_files(package, src_dir)
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 114, in find_data_files
      return self.exclude_data_files(package, src_dir, files)
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 198, in exclude_data_files
      files = list(files)
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 234, in <genexpr>
      for pattern in raw_patterns
    File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\util.py", line 110, in convert_path
      raise ValueError("path '%s' cannot be absolute" % pathname)
  ValueError: path '/' cannot be absolute
  ----------------------------------------
  ERROR: Failed building wheel for quiver-engine
    ERROR: Complete output from command 'C:\Users\user\AppData\Local\Programs\Python\Python37\python.exe' -u -c 'import setuptools, tokenize;__file__='"'"'C:\\Users\\user\\AppData\\Local\\Temp\\pycharm-packaging\\quiver-engine\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\user\AppData\Local\Temp\pip-record-jyz9exys\install-record.txt' --single-version-externally-managed --compile:
    ERROR: running install
    running build
    running build_py
    creating build
    creating build\lib
    creating build\lib\quiver_engine
    copying quiver_engine\imagenet_utils.py -> build\lib\quiver_engine
    copying quiver_engine\layer_result_generators.py -> build\lib\quiver_engine
    copying quiver_engine\server.py -> build\lib\quiver_engine
    copying quiver_engine\util.py -> build\lib\quiver_engine
    copying quiver_engine\__init__.py -> build\lib\quiver_engine
    running egg_info
    writing quiver_engine.egg-info\PKG-INFO
    writing dependency_links to quiver_engine.egg-info\dependency_links.txt
    writing requirements to quiver_engine.egg-info\requires.txt
    writing top-level names to quiver_engine.egg-info\top_level.txt
    reading manifest file 'quiver_engine.egg-info\SOURCES.txt'
    reading manifest template 'MANIFEST.in'
    writing manifest file 'quiver_engine.egg-info\SOURCES.txt'
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:\Users\user\AppData\Local\Temp\pycharm-packaging\quiver-engine\setup.py", line 21, in <module>
        'pillow'
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\__init__.py", line 145, in setup
        return distutils.core.setup(**attrs)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\core.py", line 148, in setup
        dist.run_commands()
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\dist.py", line 966, in run_commands
        self.run_command(cmd)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\dist.py", line 985, in run_command
        cmd_obj.run()
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\install.py", line 61, in run
        return orig.install.run(self)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\command\install.py", line 545, in run
        self.run_command('build')
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\cmd.py", line 313, in run_command
        self.distribution.run_command(command)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\dist.py", line 985, in run_command
        cmd_obj.run()
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\command\build.py", line 135, in run
        self.run_command(cmd_name)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\cmd.py", line 313, in run_command
        self.distribution.run_command(command)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\dist.py", line 985, in run_command
        cmd_obj.run()
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 53, in run
        self.build_package_data()
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 118, in build_package_data
        for package, src_dir, build_dir, filenames in self.data_files:
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 66, in __getattr__
        self.data_files = self._get_data_files()
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 83, in _get_data_files
        return list(map(self._get_pkg_data_files, self.packages or ()))
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 95, in _get_pkg_data_files
        for file in self.find_data_files(package, src_dir)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 114, in find_data_files
        return self.exclude_data_files(package, src_dir, files)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 198, in exclude_data_files
        files = list(files)
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\site-packages\setuptools\command\build_py.py", line 234, in <genexpr>
        for pattern in raw_patterns
      File "C:\Users\user\AppData\Local\Programs\Python\Python37\lib\distutils\util.py", line 110, in convert_path
        raise ValueError("path '%s' cannot be absolute" % pathname)
    ValueError: path '/' cannot be absolute
    ----------------------------------------
ERROR: Command "'C:\Users\user\AppData\Local\Programs\Python\Python37\python.exe' -u -c 'import setuptools, tokenize;__file__='"'"'C:\\Users\\user\\AppData\\Local\\Temp\\pycharm-packaging\\quiver-engine\\setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:\Users\user\AppData\Local\Temp\pip-record-jyz9exys\install-record.txt' --single-version-externally-managed --compile" failed with error code 1 in C:\Users\user\AppData\Local\Temp\pycharm-packaging\quiver-engine\

対応方法

インストール実行

以下のコマンドで最新版をインストールします。

> pip install git+git://github.com/keplr-io/quiver.git

実行ログ

以下はインストール成功のログです。

>pip install git+git://github.com/keplr-io/quiver.git
Collecting git+git://github.com/keplr-io/quiver.git
  Cloning git://github.com/keplr-io/quiver.git to c:\users\user\appdata\local\temp\pip-req-build-t8hx_59x
  Running command git clone -q git://github.com/keplr-io/quiver.git 'C:\Users\user\AppData\Local\Temp\pip-req-build-t8hx_59x'
Requirement already satisfied: keras in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver-engine==0.1.4.1.5) (2.2.4)
Requirement already satisfied: flask in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver-engine==0.1.4.1.5) (1.0.3)
Requirement already satisfied: flask_cors in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver-engine==0.1.4.1.5) (3.0.8)
Requirement already satisfied: gevent in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver-engine==0.1.4.1.5) (1.4.0)
Requirement already satisfied: numpy in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver-engine==0.1.4.1.5) (1.16.4)
Requirement already satisfied: pillow in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from quiver-engine==0.1.4.1.5) (6.0.0)
Requirement already satisfied: scipy>=0.14 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver-engine==0.1.4.1.5) (1.3.0)
Requirement already satisfied: h5py in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver-engine==0.1.4.1.5) (2.9.0)
Requirement already satisfied: six>=1.9.0 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver-engine==0.1.4.1.5) (1.12.0)
Requirement already satisfied: keras-preprocessing>=1.0.5 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver-engine==0.1.4.1.5) (1.1.0)
Requirement already satisfied: pyyaml in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver-engine==0.1.4.1.5) (5.1.1)
Requirement already satisfied: keras-applications>=1.0.6 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from keras->quiver-engine==0.1.4.1.5) (1.0.8)
Requirement already satisfied: Jinja2>=2.10 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from flask->quiver-engine==0.1.4.1.5) (2.10.1)
Requirement already satisfied: itsdangerous>=0.24 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from flask->quiver-engine==0.1.4.1.5) (1.1.0)
Requirement already satisfied: Werkzeug>=0.14 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from flask->quiver-engine==0.1.4.1.5) (0.15.4)
Requirement already satisfied: click>=5.1 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from flask->quiver-engine==0.1.4.1.5) (7.0)
Requirement already satisfied: cffi>=1.11.5; sys_platform == "win32" and platform_python_implementation == "CPython" in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from gevent->quiver-engine==0.1.4.1.5) (1.12.3)
Requirement already satisfied: greenlet>=0.4.14; platform_python_implementation == "CPython" in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from gevent->quiver-engine==0.1.4.1.5) (0.4.15)
Requirement already satisfied: MarkupSafe>=0.23 in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (from Jinja2>=2.10->flask->quiver-engine==0.1.4.1.5) (1.1.1)
Requirement already satisfied: pycparser in c:\users\user\appdata\local\programs\python\python37\lib\site-packages (fromcffi>=1.11.5; sys_platform == "win32" and platform_python_implementation == "CPython"->gevent->quiver-engine==0.1.4.1.5) (2.
19)
Building wheels for collected packages: quiver-engine
  Building wheel for quiver-engine (setup.py) ... done
  Stored in directory: C:\Users\user\AppData\Local\Temp\pip-ephem-wheel-cache-fpfg99ju\wheels\f8\3d\8c\01767f90bbdb04d278ca603ff5411b06a8778421a7bd01c720
Successfully built quiver-engine
Installing collected packages: quiver-engine
Successfully installed quiver-engine-0.1.4.1.5

参考

GitHub:Quiver

https://github.com/keplr-io/quiver

GitHub:Error when installing on Windows 10 with Anaconda3

https://github.com/keplr-io/quiver/issues/32

直感 Deep Learning ―Python×Kerasでアイデアを形にするレシピ

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です